Lynxmotion Tech Support

www.lynxmotion.com
Join the Accelerator Program
It is currently Thu Apr 24, 2014 4:24 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Fri Mar 23, 2012 5:46 am 
Offline
Roboteer

Joined: Fri Mar 23, 2012 5:32 am
Posts: 4
Hey Rios developpers,
I'm a 17 year old student at: Gemeentelijke Technische School Merchtem
I bought your lynxmotion robot.
We got it to work with several desktops wich have serial ports.
But Right now I have to install it on a laptop. The installation goes succesfully but when
I try to run the program i get this error:
Error reading ComComboBox1->ComProperty: Registry error (win error code:2)
I have read the topic about this problem, but it didn't provide me any help.
I also downloaded and tried to use the latest version of RIOS v1.06.
But still getting that error.
My laptop has no Serial port.
We used Serial to USB on those desktops and it worked all fine.
All drivers are OK
My laptop is a 2012 ACER, intelcoreI5,6GIG DDR3


Attachments:
File comment: The error i get when i try to run RIOS
Error.jpg
Error.jpg [ 20.53 KiB | Viewed 4931 times ]


Last edited by joeryBE on Fri Mar 23, 2012 5:49 am, edited 1 time in total.
Top
 Profile  
 
PostPosted: Fri Mar 23, 2012 5:48 am 
Offline
Roboteer

Joined: Fri Mar 23, 2012 5:32 am
Posts: 4
PLEASE REPLY AS FAST AS POSSIBLE AS WE HAVE ONLY 1 MONTH LEFT FOR THIS PROJECT !!!


Top
 Profile  
 
PostPosted: Mon Mar 26, 2012 8:39 am 
Offline
Lynxmotion Founder
User avatar

Joined: Mon Oct 31, 2005 11:46 am
Posts: 9325
Location: my quiet place
You answered your own question. Your laptop has no serial port. Plug in a usb to serial cable before starting the application. ;)

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


Top
 Profile  
 
PostPosted: Thu Apr 05, 2012 3:37 pm 
Offline
Roboteer

Joined: Fri Mar 23, 2012 5:32 am
Posts: 4
I already tried that and also correctly installed the drivers for that port... :S this is going nowhere...


Top
 Profile  
 
PostPosted: Thu Apr 05, 2012 3:50 pm 
Offline
Lynxmotion Founder
User avatar

Joined: Mon Oct 31, 2005 11:46 am
Posts: 9325
Location: my quiet place
joeryBE wrote:
I already tried that and also correctly installed the drivers for that port... :S this is going nowhere...


You are going to have to use more words. You say you are in a big hurry but you don't reply for a week and a half. The error code you posted means the software is not seeing a serial port...

What brand usb to serial cable are you using?

What driver are you installing?

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


Top
 Profile  
 
PostPosted: Wed Apr 18, 2012 3:26 am 
Offline
Roboteer

Joined: Fri Mar 23, 2012 5:32 am
Posts: 4
Never mind we solved the problem by connecting it to an old desktop.
We bought the micro controller wich we intended to save our program on. So we didn't have to connect it with the
desktop everytime it was moving. We could not find out how to get it to work so we just installed an old desktop under our project wich
is out of sight. Now we're just triggering the auxilarry gates with a siemens programmable logic controller. Not what we intended to do
but it works. We're 1 month away from our deathline now. But thx for replying so fast.


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 11:05 am 
Offline
Roboteer

Joined: Tue Nov 27, 2012 11:01 am
Posts: 6
Hi, I also have the same problem with my robot... I work on acer aspire 5741g with windows 7 64bit. I have already update all drivers but it doesn't changed anything...

Robot I use is AL5D. Rios ver 1.06. Thx for help.


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 12:19 pm 
Offline
Site Admin
User avatar

Joined: Fri Aug 31, 2012 8:45 am
Posts: 851
Can you explain the issue you are having?

_________________
Coleman Benson
Lynxmotion
Imagine it. Build it. Control it.™
http://www.Lynxmotion.com


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 12:47 pm 
Offline
Roboteer

Joined: Tue Nov 27, 2012 11:01 am
Posts: 6
I installed RIOS without any problems but when i try to lunch it I get this error: Error reading ComComboBox1->ComProperty: Registry error (win error code:2)... The same as in the first post in this topic.


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 12:57 pm 
Offline
Robot Guru
User avatar

Joined: Tue Nov 02, 2010 10:39 pm
Posts: 1697
Location: Quebec Canada
chmielik wrote:
I installed RIOS without any problems but when i try to lunch it I get this error: Error reading ComComboBox1->ComProperty: Registry error (win error code:2)... The same as in the first post in this topic.


Not all USB COM port will work with that.
I know there are thread about that if you search the forum.

_________________
Eric Nantel - DiaLFonZo
UAV/Drones Specialist

Lynxmotion
Imagine it. Build it. Control it.™
http://www.Lynxmotion.com


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 1:25 pm 
Offline
Site Admin
User avatar

Joined: Fri Aug 31, 2012 8:45 am
Posts: 851
Are you using a serial cable or a serial to USB adapter? If you are using an adapter, which one, and have you verified that it installed correctly and your computer picks it up?

_________________
Coleman Benson
Lynxmotion
Imagine it. Build it. Control it.™
http://www.Lynxmotion.com


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 2:18 pm 
Offline
Roboteer

Joined: Tue Nov 27, 2012 11:01 am
Posts: 6
I'm using a serial to USB adapter. But i didn't even connect it to my laptop... Now i see it doesn't work. I tried to install drivers but there is still the same problem. The error code is 52.


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 2:35 pm 
Offline
Robot Guru
User avatar

Joined: Tue Nov 02, 2010 10:39 pm
Posts: 1697
Location: Quebec Canada
chmielik wrote:
I'm using a serial to USB adapter. But i didn't even connect it to my laptop... Now i see it doesn't work. I tried to install drivers but there is still the same problem. The error code is 52.


If you look in device manager of windows.
Do you see that COM port ?

_________________
Eric Nantel - DiaLFonZo
UAV/Drones Specialist

Lynxmotion
Imagine it. Build it. Control it.™
http://www.Lynxmotion.com


Top
 Profile  
 
PostPosted: Tue Nov 27, 2012 2:40 pm 
Offline
Roboteer

Joined: Tue Nov 27, 2012 11:01 am
Posts: 6
Yes. But I think i have got problem with drivers for this converter... This is discrabin of the error:
Windows can not verify the digital signature of the drivers required for this device. A recent hardware or software change might have led to the installation file that is signed incorrectly or damaged, or may be malicious software from an unknown source. (Code 52)


Top
 Profile  
 
PostPosted: Wed Nov 28, 2012 9:46 am 
Offline
Robot Guru
User avatar

Joined: Sat Apr 15, 2006 2:42 pm
Posts: 4755
Yes, sounds like driver issue. Windows 64 bit often does not like these unsigned drivers. Many times, you can either go up to the manufactures website and find an updated/signed driver for it, or depending on what chipset it uses (FTDI is probably the most popular), you can go up to their website and download a driver and potentially have to manually install it.

Or simply get another adapter that has valid drivers, like the one Lynxmotion sells: http://www.lynxmotion.com/p-699-usb-to- ... cable.aspx

Kurt


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
© 2014 RobotShop Distribution inc. All rights reserved.
Powered by phpBB® Forum Software © phpBB Group