Putting robotics at your service™

Free shipping on orders over $200

ARC32 isn't connecting to terminal

Print view Share :
Previous topicNext topic

Page 1 of 1 [ 6 posts ]

Novice ( offline )
Posts: 51
Posted: 2012-02-21 23:29 
Edit: I've disconnected everything, even installed it onto my netbook and tried it there.. Still getting nothing when I try and connect the terminal. It's almost like it will load and execute a program, but otherwise won't talk to the outside world, not through the terminal, not through any PS2 controller in my house. Is it possible that some part of its serial controller is in some way damaged, where it can recieve but not send, or something like that?


Okay, I'm pretty stumped here and hoping someone can point me in the right direction.

I've got an ARC32 running the Phoenix code on my hexapod. I took the robot apart to hardwire in the ps2 reciever. Put it back together and turned it on. Lights on the rx came on and it seemed to connect to the controller, but wouldn't respond. I thought I must have messed something up, so I went and checked all my pins on the rx and it all seems fine. Then I plugged it into the computer to connect the console and check the calibration, but when I hit connect on the console, I get.. nothing.

I reloaded the code to no avail. I loaded the default ARC32 program in Basic Micro Studio that moves each servo in turn, and that worked, but when I put the Phoenix code back on, I still can't get it to connect on the terminal. Baud rate is 38.4, no parity, no flow control, no echo. Same as it always has been.



I'm not sure if this is related or not, because I don't know enough about the specifics of the board, but one of my coxa servos (645mg) cooked itself in the process. It always twitched when I first connected power, which I thought was strange, but the FET that drives the motor definitely melted while I had it plugged in trying to connect to the console.


Any help or advice would be appreciated. I'm totally baffled.


User avatar
Guru ( offline )
Posts: 4915
Posted: 2012-02-22 10:10 
Sounds pretty strange... Since it can obviously talk to the PC through the serial port as you said you could download programs... Things I would try include:
a) Run the PS2 test program... Which is part of this tutorial (http://www.lynxmotion.com/images/html/build034.htm). I would try to see if it would output in one of the Terminal windows that is part of the Basic Micro IDE. I would then try other terminal programs as well. Double check right comm port, baud rates... are selected.

I would also double check wiring. Although you did mention you undid everything... Do you have a speaker hooked up to your Arc32? I often have one of the radioshack cheap speakers hooked up. Maybe the Arc32 is hung in the PS2 init...

That is all for now.

Kurt


Novice ( offline )
Posts: 51
Posted: 2012-02-22 11:15 
Ah, I don't have a speaker on there yet. Been meaning to get one but life has been too busy. I was going to try the test program last night but it wouldn't compile for some reason and I was too tired at that point to keep going. Plus, I figured since it won't connect to the terminal even if the ps2 reciever is unplugged, something else has to be going on?

But tonight when I get home I will take another look at it, and see what other programs I can dig up that use the terminal..


Novice ( offline )
Posts: 51
Posted: 2012-02-23 00:28 
Okay, did some more messing around, this is what I found:

-I was able to connect to the terminal on any other program I tried, I just can't connect with the Phoenix code

-I wasn't getting anything from the hardwired ps2 rx, was a bad solder joing, fixed now. I tried my old plug on a wired Sony ps2 controller and I can see in the terminal for the test program that it is getting the correct data

-Still can't get it to do anything with the Phoenix code, even with the hardwired controller


I tried changing the baud rate in the Phoenix code to 9600 to see if maybe I can connect to anything but 38.4k but no luck..


Novice ( offline )
Posts: 51
Posted: 2012-02-26 01:33 
So, still having problems. Where I'm at now:

Basic Micro thinks it's an issue with the code. I downloaded a fresh copy of the Phoenix code and still had the same problem.

It seems that:

-It will execute code and connect to the terminal IF the program is small/simple

-Any of the larger programs I have tried, it won't do anything, almost like it is freezing up


At this point I'd probably buy another one if I could find somewhere in Canada that had it in stock....


User avatar
Expert ( offline )
Posts: 628
Posted: 2012-04-04 22:17 
Send it in to Basicmicro and we'll replace it. In all these years we've never had anyone have a chip that partially ran code(this could be the first). Some have had chips were individual I/Os have died but a chip has never been damaged so it only partly runs code. It's pretty much an all or nothing from out experience.

_________________
Basicmicro


 

All times are UTC - 5 hours [ DST ]. It is currently 2014-10-31 13:03
Feedback Form
Feedback Form