Putting robotics at your service™

Free shipping on orders over $75

between ssc-32 and bot board 2

Print view Share :
Previous topicNext topic

Page 1 of 1 [ 9 posts ]

New ( offline )
Posts: 2
Posted: 2011-05-26 15:14 
izzit possible to control a 5 DOF robot arm via bot board 2 without use ssc-32?

User avatar
Guru ( offline )
Posts: 9256
Posted: 2011-05-26 15:20 
Define "control" and it will be easier to answer.

Jim Frye, the Robot Guy
I've always tried to do my best...

New ( offline )
Posts: 2
Posted: 2012-07-18 04:18 

I have nearly the same question as "robotarm", I want to real time control a Lynx rover
over the PC with the Lynx Rover Control Software, is this only with an Bot Board 2 Basic Atom Pro possible ?
(controlled by Keyboard)

( Project:
- Lynx Rover
- Lynx Bot Board 2
- AMD Geode Embedded PC on Rover with Lynx Control Software installed

--> WLAN Control via other PC over Remote Desktop Connection to the AMD Geode Embedded PC )

Greetings tristez

User avatar
Expert ( offline )
Posts: 253
Posted: 2012-07-18 09:53 
The Lynx Rover Controller was written to control an SSC-32. It will not work with a BotBoardII. I have successfully controlled a wireless rover with this program using two Xbee's in transparent mode.

Devon Simmons, Former Programmer for Lynxmotion.
I can try to help, but I can only offer you my best effort.

New ( offline )
Posts: 2
Posted: 2012-07-19 02:39 

thank you for the quick answer, I think I will look for SSC-32 Board, I bought the Bot Board II because I got it over Ebay for 30€ including
the Basic Atom Pro 28PIN chip.

I also found in the forum a manual from Fish (Admin): Router controlled A4WD1 without hacking, now I'am thinking about the two
ways and which way is better.

Rover with a PC onboard or with a router controlled ?

Project Parts:
- Lynx Rover A4WD1 with 4 x motor
- Lynx BotBoard II with Basic Atom Pro 28PIN
- Wlan Router
- Moxa NPort 5110 1-port RS-232 serial device servers
- RS232 to USB Converter
- Axis and Arecont Network Camera

- Sabertooth dual 12A motor driver for R/C --> missing
- Lynx SSC-32 --> missing
- Battery packs --> missing

Greetings tristez

New ( offline )
Posts: 2
Posted: 2012-12-18 18:30 

I'm building a wireless rover controlled by a PC using Lynx Rover Controller. The issue is that Lynx Rover Controller (version V0.2.2) cannot connect to SSC 32 board, it displays "Not Connected" status and doesn't react on any icon or keyboard pressings.

At the same time I can control all servos individually (on each individual channel) using Lynx SSC 32 Terminal. The settings for Terminal are: baud rate = 115200, data bits = 8, stop bits = 1, parity = none, flow control = none. Version of SSC 32 controller is SSC32-V2.03XE. The PC and SSC 32 are connected by RS232 cable + USB-to-serial-adapter recommended by Lynxmotion (http://www.lynxmotion.com/p-699-usb-to- ... cable.aspx).

Where the connection problem could be?

User avatar
Guru ( offline )
Posts: 3301
Posted: 2012-12-18 18:47 
Comm port? Just throwing that in there.

Jonny Poole,
Freelance Concept Art & Animatronics, 3D Art and 3D Modelling, as well as Physical Modelling, Mechanical design, and illustration.
Create, Innovate, Inspire.

New ( offline )
Posts: 2
Posted: 2012-12-18 19:26 
innerbreed wrote:
Comm port? Just throwing that in there.

I am aware that previous versions of Lynx Rover Controller didn't communicate with comm port greater than 10, so I'm using COM4.

I've installed Dual Lynx Arm Controller V1404 just to check it's not my PC or a USB adapter that causing problems - apparently this software identifies the servo controller as SSC32-V2.03XE and enables the control over all servos via clicking various icons. But there is still no connection with Lynx Rover Controller though...

User avatar
Admin ( online )
Posts: 4719
Posted: 2012-12-19 10:39 
Did you configure the setting to your setup and check the pinout info to ensure that everything is connected properly?

Coleman Benson

RobotShop inc.
Putting Robotics at your service!™

Imagine it. Build it. Control it.™


All times are UTC - 5 hours [ DST ]. It is currently 2015-08-28 10:44
Feedback Form