Putting robotics at your service™

Free shipping on orders over $200

Dead SSC-32?

Print view Share :
Previous topicNext topic

Page 1 of 1 [ 4 posts ]

New ( offline )
Posts: 3
Posted: 2012-04-13 23:44 
 Post subject: Dead SSC-32?
So..I hooked up a 9Vbattery to my SSC-32. No lights. Tried 3 different batteries. Used a multimeter to test polarity. Zip.

Is my card dead? How can I check for real? No lights, no power.


User avatar
Guru ( offline )
Posts: 9256
Posted: 2012-04-16 10:52 
 Post subject: Re: Dead SSC-32?
Put 9vdc on VL with all servos and connectors removed. Measure 5vdc on the terminals by the baudrate where you see + and - silk screened on the board. If the 5vdc is there but the green led does not light, it means the processor is not working.

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


New ( offline )
Posts: 3
Posted: 2012-04-18 09:24 
 Post subject: Re: Dead SSC-32?
What do I do if the processor is not working? Can I replace the chip cheaply? I just got the board about a month or two ago :(


User avatar
Guru ( offline )
Posts: 9256
Posted: 2012-04-18 10:02 
 Post subject: Re: Dead SSC-32?
We sell replacement / upgrade chips for $9.95 http://www.lynxmotion.com/p-624-ssc-32- ... -chip.aspx

We have a 30 day replacement policy. The processor can be damaged by static discharge in handling or connecting, applying reverse voltage or applying over 5vdc to any of the pins, Incorrect firmware code or process when updating the firmware, and probably many other reasons. Good luck with it.

_________________
Jim Frye, the Robot Guy
http://www.lynxmotion.com
I've always tried to do my best...


 

All times are UTC - 5 hours [ DST ]. It is currently 2014-12-28 02:39
Feedback Form
Feedback Form